Как сделать убрать bad блоки на винте в RAID5 SR150

Поломалось, посыпалось, не работает...

Модераторы: Trinity admin`s, Free-lance moderator`s

Ответить
sergey12
Junior member
Сообщения: 16
Зарегистрирован: 05 апр 2004, 08:59
Откуда: Якутск

Как сделать убрать bad блоки на винте в RAID5 SR150

Сообщение sergey12 » 05 апр 2004, 11:32

стоит Сервер Kraftway GEG400 c контроллером Senintel RAID 150.
RAID5 с одним логическим диском c 9 винтами Maxtor ATLAS 10K III. один винт из 9-ти отключился. Этот винт отформатировал, протестировал вроде заработал. Делаю rebuild логического диска, чтобы подключить этот винт, но выскакивает ошибка 5-го винта "Bad block encountered" и rebuild отваливается. По моему пока не вылечу 5-го винта с bad блоками восстановить подключение 1 винта к RAID не получится.

как вылечить винт с bad блоками?

Аватара пользователя
gs
Сотрудник Тринити
Сотрудник Тринити
Сообщения: 16622
Зарегистрирован: 23 авг 2002, 17:34
Откуда: Москва
Контактная информация:

Сообщение gs » 05 апр 2004, 12:24

К сожалению так просто не отделаетесь - ребилд при наличии бэдов не пройдет по определению.
Только бэкап, формат (или замена) бэдового диска и создание всего с нуля.

З.Ы. Делайте периодически консистенси чек - такие приколы надо отлавливать до того как они в проблему превратятся. И разбирайтесь что произошло - так просто бэды сразу на нескольких винтах не появляются. Им могла помочь электрика или чей-то пинок. Хотя возможно бэды есть давно, просто вы их не видели - консистенси чек форева!

Ответить

Вернуться в «Массивы - Технические вопросы, решение проблем.»