Не ставится ASP Linux на IBM ServeRAID

На доскональное знание данной темы, не может претендовать, пожалуй ни один спец, из ныне живущих на земле. ;-)
Так поможем друг другу.

Модераторы: Trinity admin`s, Free-lance moderator`s

Ответить
Bloody Eagle
Junior member
Сообщения: 4
Зарегистрирован: 05 янв 2004, 13:50
Откуда: г. Саранск

Не ставится ASP Linux на IBM ServeRAID

Сообщение Bloody Eagle » 05 янв 2004, 13:57

Призагрузке с СД, загрузка доходит до loading kernel..... и тишина.
Если выдрать рэйд контроллер, то установка запускается нормально. Если кто сталкивался с такой проблемой и может помочь - буду благодарен за любую полезную информацию.
С уважением, начинающий администратор
Bloody Eagle

Аватара пользователя
setar
Site Admin
Site Admin
Сообщения: 1984
Зарегистрирован: 22 авг 2002, 12:03
Откуда: St. Petersburg

Сообщение setar » 08 янв 2004, 05:44

Идея следующая (теоритическая):
вероятно

схожие темы (могут помочь в случае запуска ядра но когда не видно массив )

http://www.3nity.ru/viewtopic.htm?t=842
http://www.3nity.ru/viewtopic.htm?t=1642

Аватара пользователя
setar
Site Admin
Site Admin
Сообщения: 1984
Зарегистрирован: 22 авг 2002, 12:03
Откуда: St. Petersburg

Сообщение setar » 08 янв 2004, 06:08

Вероятно ядро не понимает этого контроллера (что странно, его поддержка должна грузиться ips.o модулем.)

Идеи следующие:
1. пробуем отключить/включить в Bios PCI BusMastering
2. пробуем отключить в Bios ACPI
3. если в bios есть пункты с прерываниями (в часности 19 irq ) пробуем менять их.
4. ставим контроллер в другой слот, делаем сброс CMOS.


схожие темы (могут помочь в случае запуска ядра но когда не видно массив )

http://www.3nity.ru/viewtopic.htm?t=842
http://www.3nity.ru/viewtopic.htm?t=1642


про поддержку ядром здесь http://www.asplinux.ru/ru/docs/intel/intel4.shtml

Bloody Eagle
Junior member
Сообщения: 4
Зарегистрирован: 05 янв 2004, 13:50
Откуда: г. Саранск

Сообщение Bloody Eagle » 08 янв 2004, 12:17

Спасибо. Помогло. Отключил "Decode value BUS..." и что то там дальше в настройках контроллера, загрузка пошла, но почему то размер массива меньше чем ожидалось - порядка 70Гб, хотя 3 винта по 36 Гб.
Bloody Eagle

Аватара пользователя
setar
Site Admin
Site Admin
Сообщения: 1984
Зарегистрирован: 22 авг 2002, 12:03
Откуда: St. Petersburg

Сообщение setar » 12 янв 2004, 15:40

Если сконфигурировали отказоустойчивый RAID5 так и должно быть -
избыточность = цена за надёжность

объём массива (V) для разных типов raid определяется как :

V(raid5)=(n-1)*v
V(raid1)=v
V(raid0+1)=(n*v)/2

где n-число HDD (без учёта HotSpare - горячей замены)
и v-объём одного HDD

Bloody Eagle
Junior member
Сообщения: 4
Зарегистрирован: 05 янв 2004, 13:50
Откуда: г. Саранск

Сообщение Bloody Eagle » 12 янв 2004, 16:10

Linux поставился, но возникла другая проблема - теперь система не грузится! Не видит загрузочный диск, хотя при загрузке с дискеты все в порядке.
Bloody Eagle

Аватара пользователя
setar
Site Admin
Site Admin
Сообщения: 1984
Зарегистрирован: 22 авг 2002, 12:03
Откуда: St. Petersburg

Сообщение setar » 12 янв 2004, 16:27

По шагам пожалуйста, я не телепат.
"Не видит загрузочный диск"
1. нет попытки старта загрузчика (какой загрузчик, параметры, стоит ли активный раздел в fdisk ... )
2. загрузчик стартует но не завершает своей работы ( например в случае LILO видим следующие коды диагностики )
3. ошибка монтирования корня с надписью "kernel panic" вследствии отсутствия поддержки контроллера ядром (или отсутствии модуля).

Bloody Eagle
Junior member
Сообщения: 4
Зарегистрирован: 05 янв 2004, 13:50
Откуда: г. Саранск

Сообщение Bloody Eagle » 13 янв 2004, 11:19

Загрузчик АСП Лоадер.
При стандартных настройках контролера загрузчик не грузится вообще, такое ощущение, что не видит винты совсем. При изменении настроек, загрузчик запускается, но после появления надписи
loading kernel.....
система умирает.

Смотрел список поддерживаемых контролеров, там есть ServeRAID L3, а у нас ServeRAID L4. Может в этом проблема?
Мы уже пытались перепрошивать биос контролера - не помогло.
Bloody Eagle

Аватара пользователя
setar
Site Admin
Site Admin
Сообщения: 1984
Зарегистрирован: 22 авг 2002, 12:03
Откуда: St. Petersburg

Сообщение setar » 13 янв 2004, 12:24

Если грузится с дискеты то всё просто ;)
берём с дискеты файл initrd и замещаем им тот что лежит в /boot.
после чего освежаем установленный загрузчик (ему нужно map для initrd подправить). Должно работать.

По сути и смыслу: ошибка монтирования корня системы идёт из за того что файл initrd (это запакованный образ корня системы) в своём составе не содержит модуля рейд контроллера.
исправляется либо замещением с дискеты илбо пересборкой образа initrd :
#mkinitrd /boot/initrd {версия ядра}

P.S.
удостовертесь что модули контроллера есть в /lib/modules/...
и они подключены в /etc/modules.conf
P.P.S
Блин ... невнимательно читал .... это всё же ошибка загрузчика.
попробуйте LILO - этот загрузчик проще в диагностике. используйте режим linear.

Ответить

Вернуться в «Серверы - ПО, Unix подобные системы»