Сервер asp linux

На доскональное знание данной темы, не может претендовать, пожалуй ни один спец, из ныне живущих на земле. ;-)
Так поможем друг другу.

Модераторы: Trinity admin`s, Free-lance moderator`s

AndreyDV
Junior member
Сообщения: 13
Зарегистрирован: 04 янв 2004, 03:45
Откуда: СПб
Контактная информация:

Сообщение AndreyDV » 08 янв 2004, 12:51

1. PHP 5 зря, так как бета (если ты конечно не тестовую машину делаешь , а сервер).
2. Без Perl как бы не очень хорошо. Ставь.

Frigal
member
Сообщения: 33
Зарегистрирован: 26 дек 2003, 14:31
Откуда: Москва
Контактная информация:

Сообщение Frigal » 08 янв 2004, 13:19

Ладно. Думаю всё-таки пхп 4-й поставить. Наверное это правильно. А как ево поверх 5-го впихнуть?
не нафантозировал сюда ничево...

Аватара пользователя
art
free-lance moderator
Сообщения: 653
Зарегистрирован: 15 май 2003, 11:25
Откуда: SPb

Сообщение art » 08 янв 2004, 19:42

Frigal писал(а):НИ ОДИН модуль не подключается. НИ ОДИН. Всё перепробовал(до чево додумался). Блин. Как такое может быть? Жуткое дело...
1) как ставился апач?
Из исходников, через ./configure && make && maker install или по-другому?

2) проверить, может быть нужные модули УЖЕ вкомпилились, тогда подгружать их не нужно. Запустите httpd -l
он напишет, что у него есть.
Если искомый модуль по этой команде указан, то осталось закоментировать строчку LoadModule=xxxx в httpd.conf и радоваться жизни

3) не произошло ли так, что собран один апач (новый) и запускается другой?
запустить httpd -v из того места, где лежит сборка и из рабочей директории. Сравнить.

4) попробовать явно указать при сборке:
configure --enable-module=mod_access
(тогда его и подгружать не нужно)

Frigal
member
Сообщения: 33
Зарегистрирован: 26 дек 2003, 14:31
Откуда: Москва
Контактная информация:

Сообщение Frigal » 09 янв 2004, 09:56

1) именно так и ставился.
2) нужного модуля нет.
# httpd -l
core.c
prefork.c
http_core.c
mod_so.c
3) В ТОЧКУ!
# httpd -v
Server version: Apache/2.0.40
Server built: Apr 26 2003 03:27:27
А я устанавливал 1.3.28

У меня возникли подозрения, что может быть модули не подключаются из-за того, что я поставил бетта-версию пхп-5.0(может и бред, но я, откровеено, пока других причин не вижу). Где лежат конфигурационные файлики apacht 2.0 я даже не знаю - он был установлен по дефолту. Так что теперь, НАВЕРНОЕ, мне надо переустановить апач с 2.0 на 1.3 и пхп с 5.0 на 4.3. Однако, опять же, я плохо представляю как это делать. Сверху не залезет - пробовал.
Прошу помощи в этом. Или может есть идеи получше?

PS: если написать в консоле php -v, то
PHP 4.3.4 (cli) (built: Jan 5 2004 15:29:55)
Copyright (c) 1997-2003 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies
если же смотреть тестовую страницу, то там написано 5.0.0b...
не нафантозировал сюда ничево...

AndreyDV
Junior member
Сообщения: 13
Зарегистрирован: 04 янв 2004, 03:45
Откуда: СПб
Контактная информация:

Сообщение AndreyDV » 09 янв 2004, 11:17

Такое ощущение, что ты поставил RPM'ки а потом ещё сверху установил из сырцов. Ты попробовал make uninstall запустить из дирректория, где собирал php 5? именно из этого дирретория.

Frigal
member
Сообщения: 33
Зарегистрирован: 26 дек 2003, 14:31
Откуда: Москва
Контактная информация:

Сообщение Frigal » 09 янв 2004, 11:27

AndreyDV, ты абсолютно прав. Я при установке Линухов выбрал максимальную установку и, как оказалось, дистрибутив включал апач. ПХП 5.0 я устанавливал сам через ./configure, make и make install.
Всем этим я занимаюсь впервые, поэтому много нагородил. Однако все заново делать вовсе не охота. Пытаюсь разобрацца. Получается методом тыка. Потому долго и нудно. Потому и прошу хотя бы указать область. куда пальцем тыкать :)
не нафантозировал сюда ничево...

AndreyDV
Junior member
Сообщения: 13
Зарегистрирован: 04 янв 2004, 03:45
Откуда: СПб
Контактная информация:

Сообщение AndreyDV » 09 янв 2004, 11:31

Со всеми бывает поначалу :)
Так у тебя сохранился в целости тот дирректорий, где ты собирал php? и если да, то пробовал make uninstall из того же дирректория где его собирал?

Frigal
member
Сообщения: 33
Зарегистрирован: 26 дек 2003, 14:31
Откуда: Москва
Контактная информация:

Сообщение Frigal » 09 янв 2004, 11:37

make uninstall я пробовал. Нету ключа uninstall. А Makefile здоровый и я не представляю как в нем разобрацца. Протовал в 4.3 make reinstall - невзошло... Вот.
не нафантозировал сюда ничево...

AndreyDV
Junior member
Сообщения: 13
Зарегистрирован: 04 янв 2004, 03:45
Откуда: СПб
Контактная информация:

Сообщение AndreyDV » 09 янв 2004, 11:47

тогда я бы с сайта производителя взял бы последний стабильный php4, собрал бы его и сделал бы make install

Frigal
member
Сообщения: 33
Зарегистрирован: 26 дек 2003, 14:31
Откуда: Москва
Контактная информация:

Сообщение Frigal » 09 янв 2004, 11:56

make install сверху не залазиет(делал и для пхп и для апач). Итог:
У меня сейчас стоит и нормально работает апач 2.0(который по дефолту стоял) + пхп(непонятно какой, ибо когда в онсоле пишу php -v, то пишет, што 4.3, а если тестовый файл открываю(<? phpinfo(); ?> ), то говорит, што 5.0b) + mysql. Однако требуется подключить с десяток модулей(они были в настройке старого апача и без них сайт не работает). Обычным LoadModule в httpd.conf не подключается непонятно почему.
не нафантозировал сюда ничево...

AndreyDV
Junior member
Сообщения: 13
Зарегистрирован: 04 янв 2004, 03:45
Откуда: СПб
Контактная информация:

Сообщение AndreyDV » 09 янв 2004, 12:03

Быстрее переставить корректно линух, раз тебе не понять что и как у тебя стоит. Его переустановка - 1 час с первичной настройкой стандартного ПО.
Я просто затрудняюсь не видя ситуации. Я бы решился почистить вручную по файликам, но тебе бы этого не советовал делать самому.

Frigal
member
Сообщения: 33
Зарегистрирован: 26 дек 2003, 14:31
Откуда: Москва
Контактная информация:

Сообщение Frigal » 09 янв 2004, 12:16

Вот как раз этова я больше всего делать не хочу...
не нафантозировал сюда ничево...

AndreyDV
Junior member
Сообщения: 13
Зарегистрирован: 04 янв 2004, 03:45
Откуда: СПб
Контактная информация:

Сообщение AndreyDV » 09 янв 2004, 12:32

Ну что ж, тогда даже не знаю что тебе посоветовать.

Аватара пользователя
setar
Site Admin
Site Admin
Сообщения: 1984
Зарегистрирован: 22 авг 2002, 12:03
Откуда: St. Petersburg

Сообщение setar » 12 янв 2004, 15:04

to Frigal
расковыривать то что уже наставилось сложнее чем сделать заного.

есть необходимость расписать процесс полной установки web server`a (статья)?

Frigal
member
Сообщения: 33
Зарегистрирован: 26 дек 2003, 14:31
Откуда: Москва
Контактная информация:

Сообщение Frigal » 13 янв 2004, 12:37

Сетар, было бы приятно ВСЁ и СРАЗУ.
не нафантозировал сюда ничево...

Ответить

Вернуться в «Серверы - ПО, Unix подобные системы»