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1. Product names
Adobe® InDesign & InCopy CS2® and Citrix® MetaFrame® Terminal Services.

2. Document overview
This document explains how an IT manager can reliably install and host Adobe InDesign & InCopy CS2 on a Citrix 
MetaFrame server and have the applications published to a Windows clients using the Citrix client software. This docu-
ment assumes that you have a basic understanding of the Windows Server/Client operating system, Citrix® MetaFrame® 
Server/Client software, and Adobe InDesign & InCopy CS2 installer software.

A list of the Known Issues documented by Technical Support can be accessed by using the Citrix keyword via the Adobe 
Technical Support Knowledge Base. 

Here is also the URL for Citrix MetaFrame Server home page 
http://www.citrix.com/lang/English/home.asp

3. Product overview
Adobe Systems has validated the installation procedures and the remote application launching and running of 
Adobe InDesign & InCopy CS2 using Citrix MetaFrame Server. 

Important Note: We do recommend you refer to the Adobe InDesign and/or InCopy CS2 Installer documentation in 
the User Guide as well as the Citrix document—“Citrix Metaframe XP Server for Windows with Feature Release 3 Adminis-
trator’s Guide.”

3. 1. System requirements

You can find the system requirements for InDesign & InCopy CS2 products at the following locations:
3. 1.2 InDesign CS2

http://www.adobe.com/products/indesign/systemreqs.html

3. 1.3 InCopy CS2 Standard

http://www.adobe.com/products/incopy/systemreqs.html

3.2 The environments used for validation were set up in the following ways:
Host—An English Windows 2000 Server SP 4 with Windows Terminal Server that is a member of an Active Directory domain.

Citrix—Citrix Metaframe XPe Feature Release 3

System Partition and Application partition moved from c: and d: to m: and o: respectively using the Citrix driver-
emap.exe utility.

Applications were deployed via the NFuse web portal.

Important Note: Our validation environment did not include other Languages like Japanese or other Citrix technolo-
gies like Presentation Server 3.0 or Program Neighborhood, etc.

3.3 End-User Licensing Guidelines
You must have a valid license to the desktop version to respective InDesign or InCopy software (“Software”) for all users 
who have access to the Software on a Citrix Metaframe terminal server -- not for the number concurrent users.  All use is 
limited to users on your Internal Network, as defined in the Software End User License Agreement.  This section is provide 
to provide some clarity of the terms of the EULA, but does not supercede the terms of the EULA.  In the event of any conflict 
between the terms of this User Document and the EULA, the terms of the EULA shall control. (See Section 2.3 of the EULA)

•

•
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4. Installing InDesign and InCopy 
4.1 Install InDesign CS2 or InCopy CS2 on a Citrix MetaFrame Server:

Important Note: Only non-Activating versions of InDesign and InCopy CS2 are supported in a Citrix environment. 
(Please see the Known Issues section in this document for more information regarding Software Activation.)

These installations steps are based upon the specific environment indicated in the Environment section of this document. 

4.1.2 Put Terminal Server into Install mode:
The first step in installing an application on a Terminal Server machine is to put it into install mode:

1. Choose Start > Run

2. Type cmd and press enter

3. At the command prompt, type change user /install

4.1.3 Running the application installers
Important Note: In order to ensure that all required, shared files are properly installed, you must run the InDesign or 
InCopy CS2 installer from the desktop for the target server. Do not run the application installers from a network server. 

1. Navigate to and double-click the InDesign CS2 or InCopy CS2 Application installer.

2. Click on the welcome screen.

3. Choose US English and click Next

4. Click Accept to accept the License Agreement.

5. Enter your name, your organization, and the serial number that came with the product and then click Next.

6. If you are installing InCopy, choose a Setup type; select Complete radio button and click Next. If you are not installing 
InCopy, continue with the next step.

7. Select the folder to install the application to, and click Next.

8. Click Install.

9. After the installation is complete, click Finish.

4.1.4 Publish the Application(s) via Citrix
1. Start the Management Console for Metaframe XP

	 — To start from the Citrix toolbar, click the button that has a person’s head, an app, and a server icon on it.

	 — To start if you don’t have the toolbar, double-click ctxload.exe in Program Files\Citrix\Administration.

(replacing c: with the drive letter of your system drive if necessary)

Important Note: Once you start the Management console, you’ll see a list of your farms on the left hand side. If 
needed, type your user ID and password, to authenticate to the farm.

2. Click + (plus) next to the farm to which you want to install the InDesign CS2 or InCopy CS2 applications.

3. Right click the Applications folder icon that is within the farm you just expanded and choose Publish

Application. The Citrix Application Publishing Wizard will start. All of the following steps take place within the

Citrix Application Publishing Wizard.

4. Enter a Display Name for the application. If you’re not sure what to enter then use the name of the application (InDe-
sign CS2 or InCopy CS2). The Application Description text field is optional.

5.  Click “Next”.

6. Click Browse under the Command Line text field.
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7. Navigate to where the InDesign CS2 or InCopy CS2 Application is installed and select the InDesign.exe or InCopy.exe file. 
If you performed a standard install of InDesign this path will be c:\Program Files\Adobe\Adobe InDesign CS2\InDesign.exe. 
[The standard install path for InCopy is the same, only with InCopy CS\InCopy.exe at the of the path.]

8. Click “OK”.

9. Leave the default values for the Working Directory text fields, and click Next. 

10. Leave the default values on the Program Neighborhood Settings screen, and click Next.

11. Set the Specify Application Appearance values so they meet the minimum requirements for InDesign or InCopy. If you 
are unsure what values to set, select Fullscreen for Session Window Size, and True Color for Colors.

12. Click “Next”

13. Choose settings on the Specify The ICA Client Requirements screen based on your security and deployment require-
ments. If you are unsure what settings to choose, leave everything at the default setting, and click Next.

14. Specify the servers to which you will publish the application. Choose a server on the left and click Add to list it on the

right hand side; this indicates the application will run on that server.

15. Click Next.

16. Specify the Users who can use the published application. You can use any of the following scenarios:

	 —If there is a specific group that you wish to give usage privileges to, you can drill down through the domain tree 
and locate that group. To add the group, click Add and it will be listed in the box on the bottom of the window.

	 —If you want to let anyone on your network use the application, select Allow Anonymous Connections.

17. Click Finish to publish the application and make it available for network use via Citrix.

18. If you need to install another application (InDesign CS2 or InCopy CS2) then return to step 2.

Important Note: After you install InDesign or InCopy, the application installer may prompt you to restart the server. If 
you receive this prompt, Adobe strongly recommendeds that you restart the system.

4. 2 Access InDesign & InCopy CS2 from a Windows client computer 
Important Note: These access instructions are specific to the environment as documented in section 3.2

1. Start your Web browser and enter the URL specified by the IT Manager for Web Access to the Citrix MetaFrame Server

2. Enter your specified Username & Password when the Citrix MetaFrame Login main window displays and then click 
Log-in.

Note: IT Managers can set up the server to allow users to select the option, “Desktop Credential Pass-through” or they 
may require users to select the option, “Explicit User.”

3. Double-click the icon to start InDesign or InCopy in the Citrix MetaFrame Applications window.

Important Note: The IT Manager may grant application access rights on a user-by-user basis.
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5. Basic acceptance tests for InDesign and InCopy
5.1 After you complete the installation of InDesign or InCopy, test the application on a target computer. This 
section details tests you can perform to ensure that you installed InDesign & InCopy CS2 successfully.

To verify that InDesign and InCopy plug-ins installed:

1. Start InDesign or InCopy, and then verify that no error messages appear on the startup screen.

2. Choose Help > Configure Plug-ins and in the Sets Popup Menu select the option All Plug-ins.

3. In the Display section, deselct Enabled and make sure that Disabled is selected. Verify that there are no Disabled plug-
ins listed in the Scrollable Window. 

Important Note: You can also select plug-ins individually in the window, and then click Show Info to get more infor-
mation about the plug-in, including confirmation that the plug-in is loaded and enabled.

5.2 Check that basic file acctions and commands work correctly
To check that basic file actions and command work correctly, do the following basic file actions and commands on the 
target computer after you successfully start the applications and verify all plug-ins are loaded and properly enabled:

1. Choose File > New > Document and click OK with the application defaults

2. Choose File >Save As (InDesign) or File > Save Content As (InCopy) and choose a local or server directory and name the 
file, and then click OK.

3. Choose File > Open and navigate to a directory that contains either an existing InDesign document (INDD) or an exist-
ing InCopy document (INCD or INCX), select the document, and then click Open.

4. Make some modifications to the document, select File > Save a Copy (InDesign) or File > Save Content Copy (InCopy), 
and then click OK.

5. Perform InDesign specific acceptance testing:

	 a. Choose File > Place and navigate to a directory containing file types that InDesign uses and confirm that

you can place all of the following file types successfully: JPG, PSD, TIFF, EPS, AI, PDF, DOC, RTF, XLS,

and XML.

	 b. Confirm that you can edit the text files in both Layout and Story views

	 c. Confirm that you can apply all transformations supported by InDesign to the Placed graphic files in step 5.

	 d. Confirm you can Print and Export a PDF file.

6. Perform InCopy specific acceptance testing:

	 a. In a new InCopy document, choose Type > Fill with Placeholder Text.

	 b. Switch to Story or Galley View and choose Changes > Track Changes in Current Story.

	 c. Select the first paragraph and press Delete .

	 d. Select a sentence in the second paragraph and choose Notes > Convert to Note.

	 e. Choose Notes > Expand/Collapse Notes In Story.

	 f. In the second paragraph, type a new sentence.

	 g. Switch to Layout View. place a text insertion point in the beginning of the third paragraph, press F8 to

display up the Notes palette, and then enter a note and press F8 again.

	 h. Choose File > Save Content As, and then close the document.

	 i. Choose File > Open, select the document saved in step h, and then verify that all edits were preserved..
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6. Removing InDesign and InCopy
6.1 Removal instructions

6.1.2 Removing InDesign or InCopy from a Citrix Server consists of deleting the published application from the Citrix 
Management Console, then removing the application using the standard Add/Remove Programs Control Panel.

6.1.3 Delete the published application from the Citrix Management Console
1. Start the Management Console For Metaframe XP in one of the following ways:

	 —Click the button on the Citrix tool bar which has a person’s head, an app, and a server icon on it.

	 —Run it from Program Files\Citrix\Administration\ctxload.exe.

Important Note: Once the Management console has launched, you’ll see a list of your farms on the left hand side.

2. Expand the farm object where the InDesign/InCopy application is installed.

3. Click on the Applications folder to display your InDesign and InCopy applications should be shown in the main pane of 
the window.

4 Right click on InDesign CS2 or InCopy CS2, and choose Delete Published Application.

5. Click Yes on the confirming dialog. 

6. Repeat step 4 if necessary to remove the other InDesign CS2 or InCopy CS2 application.

7. Close the “Management Console for Metaframe XP”

6.1.4 To remove the application using Add/Remove Programs
1. Choose Start > Settings > Control Panel > Add/Remove Programs

2. Select either InDesign CS2 or InCopy CS2 by clicking on it’s name in the list of currently installed programs.

3. Click Change/Remove beside the application you want to remove to start the Adobe’s InstallShield® Wizard, then click 
Next.

4. Select Remove, and then click Next.

5. Click Remove

6. Click Finish on the verification screen to leave the uninstaller.

7. Repeat steps 2-6 to remove the other application.

7. Troubleshooting
Contacting Adobe Technical Support

If you need to contact Adobe Technical Support, please prepare answers to the following questions so that we can better 
assist you:

1.   Which Server Operating system and version number is the Citrix MetaFrame-based server running? Which Service 
Pack (if any) has been applied to the server operating system?

2.  Which version of the Windows client operating system is the client computer? Which Service Pack (if any) has been 
applied to the client operating system? Do these programs meet the environment requirements listed in Environments 
section in this document?

3. Which version of the Citrix MetaFrame Server software are you currently running? Which Citrix Hotfixes and Service 
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Packs have you installed? 

4.  What is the problem statement (for example, “When I do X with Y, Z happens”)? If the problem produces an error mes-
sage, what is the exact wording of the message?

5.   Which user profile is logged into the server (for example, Administrator or Power User)? Does the problem occur when 
an Administrator profile is logged into the server?

6.   Which user profile is logged into the client computer (for example, Administrator or Power User)? Does the problem 
occur when an Administrator profile is logged into the client computer?

7.   Can you reproduce the problem when you test the problem on the server? If so, what steps reproduce the problem?

8.   What goal are you trying to achieve? Have you been able to achieve this goal in the past? If so, did anything change 
recently in your environment that might be related to the problem?

8. Known Issues 
The following list indicates known issues with installation procedures and the remote application execution of 
Adobe InDesign CS2 and InCopy CS2 using Citrix MetaFrame Server:

 The following error is displayed when you try to launch the Activation versions of InDesign CS2 or InCopy CS2 using the 
Citrix MetaFrame Server software:

“An error has been detected with a required application library and the product cannot continue. Please reinstall the 
application”. Click OK.

Important Note: Only non-Activating versions of InDesign and InCopy CS2 will be supported in a Citrix environment.

What is Software Activation:
Several Adobe products include activation technology that helps prevent unauthorized copying of the software.

Activation is an interactive representation of the license agreement between Adobe and its valued customers. Activation 
protects the intellectual property and innovation at the heart of the software industry.

Adobe is committed to eliminating unauthorized use of its software in a manner designed to have a minimal impact on 
licensed users. Versions of Adobe software that incorporate activation are provided under the same license as those ver-
sions not including activation

9. Support Statement for Windows Terminal Services 
Adobe InDesign and InCopy CS2 supports Windows Terminal Services and Citrix Server/Client configurations.  
Citrix MetaFrame Server implementations leverage core Microsoft Windows Terminal Services. Adobe has 
performed limited testing with standard Microsft Windows Terminal Services for Windows 2000 Server. Our 
testing coverage focused on basic file actions consisting of the following:

1. Remote Launching of the applications

2. Creating and Saving new documents

3. Opening existing documents 

6


